• 欢迎访问趣尚博客、分享互联网、软件、编程、创业、英语、VPS 推荐使用最新版火狐浏览器和Chrome浏览器访问本网站
  • 如果您喜欢我的博客,那么请使用Ctrl+D 收藏吧!

CentOS 卸载 CURL

Linux qushang 3年前 (2018-11-01) 4082次浏览
 Multilib version problems found. This often means that the root
      cause is something else and multilib version checking is just
      pointing out that there is a problem. Eg.:

        1. You have an upgrade for curl which is missing some
           dependency that another package requires. Yum is trying to
           solve this by installing an older version of curl of the
           different architecture. If you exclude the bad architecture
           yum will tell you what the root cause is (which package
           requires what). You can try redoing the upgrade with
           --exclude curl.otherarch ... this should give you an error
           message showing the root cause of the problem.

        2. You have multiple architectures of curl installed, but
           yum can only see an upgrade for one of those architectures.
           If you don't want/need both architectures anymore then you
           can remove the one with the missing update and everything
           will work.

        3. You have duplicate versions of curl installed already.
           You can use "yum check" to get yum show these errors.

      ...you can also use --setopt=protected_multilib=false to remove
      this checking, however this is almost never the correct thing to
      do as something else is very likely to go wrong (often causing
      much more problems).

      保护多库版本:curl-7.29.0-46.el7.x86_64 != curl-7.50.3-1.el7.centos.x86_64
[Error] Failed to install curl

安装SS的时候出现CURL报错,打算重装。

使用命令,查看当前的CURL版本

rpm -q curl

显示

curl-7.12.1-8.rhel4

直接使用命令卸载

rpm -e --nodeps curl-7.12.1-8.rhel4

 


极客公园 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:CentOS 卸载 CURL
喜欢 (9)
[399397742@qq.com]
分享 (0)